Sub-set of toll free numbers experiencing long ring times
Incident Report for CallTrackingMetrics
Resolved
This incident has been resolved.
Posted May 18, 2017 - 14:16 EDT
Monitoring
We have identified and are monitoring the issue with the impacted carrier.
Posted May 18, 2017 - 10:44 EDT