Master Card Payment Issues
Incident Report for CallTrackingMetrics
Resolved
Reports indicate Master Card has recovered.
Posted May 10, 2018 - 11:05 EDT
Update
We have confirmation from MasterCard that they are having a global outage.
Posted May 10, 2018 - 09:54 EDT
Investigating
Our system is currently unable to process charges for accounts funded with Master Cards. We are working with our payment processor to resolve the issue.
Posted May 10, 2018 - 09:31 EDT