Twilio Service Delays
Incident Report for CallTrackingMetrics
Resolved
The issue has been resolved and all functionality is restored. Thank you for your patience and further thanks for choosing CallTrackingMetrics.
Posted Mar 30, 2020 - 17:44 EDT
Monitoring
Our upstream provider has taken corrective action and we are seeing recovery. Work continues on clearing the backlog of processing that accumulated during the issue.
Posted Mar 30, 2020 - 17:42 EDT
Identified
We have mostly mitigated the impact of live calls and the issue is only impacting end of call reporting. We'll continue to work with Twilio to resolve the issues that continue related to REST API calls to the their endpoints timing out.
Posted Mar 30, 2020 - 16:44 EDT
Investigating
We are currently investigating elevated errors from Twilio. This is causing some processing delays at the end of phone calls and delays in receiving text messages.
Posted Mar 30, 2020 - 16:33 EDT
This incident affected: Calls (Incoming Phone Calls, Incoming Client Calls, Outgoing Phone Calls, Outgoing Client Calls, Secondary Carrier Inbound Phone Calls) and Texts (Incoming Text Messages).