Site Slowness
Incident Report for CallTrackingMetrics
Resolved
Everything should be good now; thanks for using CTM.
Posted Aug 14, 2017 - 16:43 EDT
Monitoring
We have identified the issue and moved onto the monitoring phase.
Posted Aug 14, 2017 - 14:07 EDT
Investigating
We are investigating an issue with our database and delayed updates in the call log.
Posted Aug 14, 2017 - 14:01 EDT