Payment Processor Issues
Incident Report for CallTrackingMetrics
Resolved
Our upstream payment processor is again operating normally. Thank you for your patience.
Posted Jul 17, 2018 - 22:20 EDT
Monitoring
Our upstream payment processor has implemented a fix and we are continuing to monitor. We observe recovery and customer payments are being processed as normal.
Posted Jul 17, 2018 - 21:55 EDT
Identified
Our payment processor is currently working towards a resolution of the issue that is causing customer payments to erroneously decline.
Posted Jul 17, 2018 - 20:35 EDT
Investigating
We are investigating an issue with our payment processor that is causing customer payments to erroneously decline.
Posted Jul 17, 2018 - 20:26 EDT