CallTrackingMetrics Marketing Site Outage

Incident Report for CallTrackingMetrics

Resolved

Our vendor has identified and resolved the network issue affecting our marketing site. Our CallTrackingMetrics platform was never affected.
Posted Sep 14, 2023 - 14:34 EDT

Identified

Our vendor is working on a networking issue. Our CallTrackingMetrics platform remains unaffected.

To login you can go directly to https://app.calltrackingmetrics.com/
Posted Sep 14, 2023 - 13:39 EDT

Investigating

Our marketing site is experiencing an outage. Our CallTrackingMetrics platform is unaffected.

To login you can go directly to https://app.calltrackingmetrics.com/
Posted Sep 14, 2023 - 13:23 EDT
This incident affected: Application Availability.