Investigating issue with site availability and delayed jobs

Incident Report for CallTrackingMetrics

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 07:54 EDT

Update

We are still working to clear delayed transcriptions.
Posted Jul 28, 2025 - 17:46 EDT

Update

We are continuing to monitor delayed transcriptions.
Posted Jul 28, 2025 - 16:37 EDT

Update

We’ve resolved the majority of the delays affecting service earlier today. While some residual disruptions may still occur, these are expected to taper off throughout the afternoon.
Thank you for your patience and continued support.
Posted Jul 28, 2025 - 15:03 EDT

Update

We are still monitoring the backlog of jobs including transcriptions.
Posted Jul 28, 2025 - 13:35 EDT

Monitoring

Mitigation in place. Delays in analytics and transcriptions are being addresssed.
Posted Jul 28, 2025 - 12:25 EDT

Identified

Issue identified and being mitigated.
Posted Jul 28, 2025 - 11:55 EDT

Investigating

We are currently investigating this issue.
Posted Jul 28, 2025 - 11:48 EDT
This incident affected: Calls (Incoming Phone Calls, Incoming Client Calls, Outgoing Phone Calls, Outgoing Client Calls, Twilio Outgoing SIP Calls, Twilio WebRTC), Texts (Incoming Text Messages, Twilio Outgoing SMS), and Application Availability.